Skip to main content

Dev Notes - VMBuild Machine Setup

Installation Procedure for FreeBSD 12.x

 

For internal Build Only - Procedure prior to Cross Compilation of all MaXX modules and apps.

 

After Normal Installation, let’s fetch and install updates

 

$ su -
freebsd-update fetch
freebsd-update install
 
Update/upgrade packages
$ su -
pkg update
pkg upgrade
pkg git vim automake autoconf libtool
 
Install Extra Development packages
$ su -
pkg git vim automake autoconf libtool
 
Install xorg and mate packages
$ su -
pkg install xorg xorg-macros xorg-sgml-doctools freetype fontconfig
pkg install mate

pkg install chromium 

pkg install gdb vscode gedit meld

 

Edit /etc/rc.conf and add the following lines
dbus_enable="YES"

 

 

Install virtualbox guest additions  package
$ su -
pkg install virtualbox-ose-additions

 

 

Edit /etc/rc.conf and add the following lines
vboxguest_enable="YES"
vboxservice_enable="YES"

 

 
Add the following content to  /usr/local/etc/X11/xorg.d/xorg.conf 
Section "Device"

    Identifier "Card0"
    Driver "vboxvideo"
    VendorName "InnoTek Systemberatung GmbH"
    BoardName "VirtualBox Graphics Adapter"

EndSection

 

Using Ports on FreeBSD How To:
$ su -
cd /usr
portsnap fetch
portsnap extract
portsnap update